Flexihub transmitting out on USB-RS485 connection(Read 4735 times)
Flexihub transmitting out on USB-RS485 connection on: April 25, 2016, 01:05:39 PM
Hi there. I wasn't sure where to post this, so if it's in the wrong place, feel free to move it.

I'm using flexihub to monitor an RS485 debug port on a custom embedded device. The setup I have is:

Device -> RS-485 -> FTDI USB converter -> Windows Laptop -> Flexihub -> LAN -> Windows PC -> Tera Term

I can connect fine and can see the debug information being displayed in Tera Term, so there's no problem there.

The problem I have is that the debug port on this specific device is also used to update the firmware and it's programmed to reset itself into bootloader mode if it sees ANY incoming character from the RS485 cable because it assumes that the software update software is trying to talk to it.

What I'm seeing when I connect with FlexiHub is the device resetting every now and then, so it's as if something is transmitting out to the device.

Has anyone experienced anything like this? Is there any kind of 'keep alive' signal being sent by the Flexihub software or driver that I need to disable?

Any help on this would be very much appreciated.



Re: Flexihub transmitting out on USB-RS485 connection Reply #1 on: April 25, 2016, 04:51:04 PM
Would you be able to send us at support@eltima.com the Flexihub logs from your Windows laptop after reproducing the problem? You can get them under "File" -> "Save internal logs".

It would also help if you install our Serial Port Monitor tool on your laptop, reproduce the problem while recording a monitoring session on the COM port, and also send us that session for investigation.

Thanks.



Re: Flexihub transmitting out on USB-RS485 connection Reply #2 on: April 26, 2016, 03:26:38 PM
I found out what was causing the issue. I was connecting to the RS485-USB device, rather than the COM port assigned to it by the connected laptop. This was creating another COM port on my local machine that was then being shared back through Flexihub.

Connecting to the COM port assigned by the remote machine works perfectly.

I don't know whether the log will still be useful to you, let me know if you still want me to recreate the issue.



Re: Flexihub transmitting out on USB-RS485 connection Reply #3 on: April 27, 2016, 01:54:51 PM
Thanks for your feedback, I'm glad you were able to sort things out.



 

Sitemap 1 2 3 4 5