Flowcontrol problem.(Read 8249 times)
Flowcontrol problem. on: March 09, 2010, 02:36:56 AM
I'm using Virtual Serial port activeX control version 6(OEM license).
My issue is about flow-control.
My application makes 70 virtual com ports and a serial terminal use these ports.
There is no problem when a serial terminal doesn't use flow-control.
But, there is a serious problem when a serial terminal use flow-control.
Sometimes, my application is stopped(lock down) and doesn't answer any request or terminated with an error.
Sometimes, my system is crashed with blue screen.

I guess this problem is occurred when my application or a serial terminal try to send a data to virtual com port after flow-control is raised.

My application can modify to avoid this situation.
But, various serial terminals ( especially huge kind of serial programs of our clients ) can't.
So, this problem will happen one of my clients.

Do you have any idea about this problem?

Actually, i have sent a email about this issue to Eltima's support team a long time ago.
But, they don't answer me yet.





Re: Flowcontrol problem. Reply #1 on: March 09, 2010, 01:34:59 PM
Dear Jack,

Please, let me know whether you received my email (January 21, 2010) with new drivers for Virtual Serial Port ActiveX Control attached. I've just resend it. Please, let us know the test results.



Re: Flowcontrol problem. Reply #2 on: March 10, 2010, 01:01:49 AM
OK. I got your mail.
Thank you.



Flowcontrol problem Reply #3 on: December 23, 2011, 09:04:20 PM
Last line of this code gives this error: IPTxShFolder::PathName is not accessible.
Is this a problem with Borlands ActiveX wrappers?

Ive been planning to use ActiveX under BCB6 so I dont have to buy ActiveX and VCL for different environments but with that kind of problems looks like  I have no choice



Re: Flowcontrol problem. Reply #4 on: December 26, 2011, 01:20:33 PM
Please send us your request via e-mail to support@eltima.com, describing the problem in more detail.
Thank you



 

Sitemap 1 2 3 4 5