evserial service FAILURE(Read 13624 times)
evserial service FAILURE on: March 10, 2010, 02:55:09 AM
I'm getting errors during installation when my installer (MSI created by Visual Studio 2008) runs vspdxp_install.exe.

The first error is "Cannot create evserial service FAILURE: The specified service has been marked for deletion."

The second error is "Main FAILURE: The specified service has been marked for deletion."

Any ideas on where to start looking for a cause?  This is on a Vista PC.



Re: evserial service FAILURE Reply #1 on: March 10, 2010, 12:44:57 PM
Hello,

We are ready to investigate the problem. Could you, please send us your installer and detailed instructions on how the problem can be reproduced? Did you try to reboot your PC? The problem you described usually occurs if you try to reinstall the drivers without reboot. We would recommend you to use the vspdxp_install.exe and vsbsetup.exe from the latest installer.



Re: evserial service FAILURE Reply #2 on: March 10, 2010, 02:28:25 PM
The error occurred during an upgrade install on a particular (single) machine.  However we were able to eliminate the error message after a reboot.

We've never had to reboot before during any kind of install, upgrade or otherwise.  So maybe it was something unique to that particlar machine, or something to do with Vista UAC?  Either way, I wish that the error message was something more "user-friendly". 

Since our installer calls the VSP driver installer, which generates the error, I don't think there is much we can do about it on our end, unless you have a suggestion.  I would like to anticipate these issues before we make a release and make our install/upgrade process as seamless as possible.

Thank you.



Re: evserial service FAILURE Reply #3 on: March 12, 2010, 10:00:02 AM
Hello,

I kindly ask you to confirm that you are using vspdxp_install.exe and vsbsetup.exe from the latest installer.

Thank you.



Re: evserial service FAILURE Reply #4 on: March 12, 2010, 12:59:08 PM
It turns out this was happening only on an upgrade from a particular previous build of our application from one or two years ago.  This particular build may not have been done properly - possibly as you suggested with the incorrect version of vspdxp_install.exe or some other cause.  So when our newest installer attempted to upgrade (and thus run the older version's uninstaller) it received the error. 

I think we can close this issue as upgrades from newer releases don't exhibit the issue.  Thank you.



 

Sitemap 1 2 3 4 5