Create a chart

In order to start creating charts follow the steps below:

   1. If you already have a saved Java Chart Designer project, click “File” menu option and select “Open” or select “Start” tab in “Quick access panel” and press “Open” button. If you would like to create a new project then click “File” menu option and choose “New” item or select “Start” tab in “Quick access panel” and press “New” button.
   2. If you have created a new project in the previous step then you will be prompted to select the following:

  •           chart type as shown below:

jc_chart_type_column jc_chart_type_bar
jc_chart_type_line jc_chart_type_area
jc_chart_type_pie jc_chart_type_dough
jc_chart_type_xy jc_chart_type_bubble
At the left side you may choose among 8 different categories such as columns, bars, lines, areas, pie, doughnut, xy and bubble and at the right side chart type itself. For more information about all available chart types please consult Changing chart type page. Once you select necessary chart type press “Next” button to proceed.

  • enter data parameters and values:

jc_data_value_1
To get more information how to modify chart data consult Changing chart data page. When you are satisfied with the data you entered press “Next” button to proceed.

  • Optionally, you may specify chart title, subtitle, footer text and series/categories lables:

jc_data_titles_1

Please, note that you may change those values later on using “Options&Data” tab. Click “Next” button to proceed.

  • Finally, you may define chart’s style:

jc_data_style_1
   We do encourage you to modify chart settings to suit your taste and needs and achieve astonishing results. You may do it from “Options & Data” menu or from “Options & Data” tab at Quick access panel. For more information about chart parameters modification options consult Settings page.
   4. Save your work into one of available formats:

  •           Java applet
                This is useful format if you aim for web users and want to insert a chart into HTML page. Unlike JPEG format, Java applet possesses rich animation and other effects, however, to be able to view Java applets you and your users must have Java-enabled browser. To save a chart as Java applet click “File” menu and choose “Generate Applet” option or select “Save” tab in Quick access panel and press “Generate Applet” button. New “Generate Applet” window will pop-up:
    jc_generate_applet
                Click “Add …” button to select a chart you saved in .ELC format and once it is added click “OK” button and select the name and location of your Java applet file. Please, note that the chart will be saved as .JAR (Java archive) file
  •  JPEG image
                JPEG images can be easily inserted into a web-page as well as Word/Excel/PowerPoint presentation. In order to save chart as image click “File” menu option and choose “Save as JPEG” or click “Save” tab in Quick access panel and press “Save as JPEG” button. Please, note that if you have animation in your chart it will not be saved in image.
  •  proprietary .ECL format
                ECL is intermediate format which can’t be directly used in any other application except Java Chart Designer. You may save your chart in this format for further processing. In order to save your chart click “File” menu and choose “Save” option to save your chart with current name or “Save as” to save with the new one.